Improbable Icon

All builds getting: Error building Player because scripts had compiler errors but no errors found


#1

Let me start off by saying that even tho we just started hooking up the networking on our game to SpatialOS we love it…

I have a strange issue. I have spatial on 2 computers so far for dev work and I went to install it on the 3rd. Every thing seemed to go fine, until I went to build: (used The Pirate Demo and the StarterProject with no changes, fresh off your site and I even pulled a project from a different computer that would build and got the same thing)

Error building Player because scripts had compiler errors
  Error building Player because scripts have compile errors in the editor
  Error building Player because scripts have compile errors in the editor
  Error building Player because scripts have compile errors in the editor

Most of the errors are in the logs are that it can not find namespaces (Even MonoBehavior)…

Now when I

  • Load Unity3d (5.6.0f3) I find no errors (not even a warning)

Spatial diagnose:
C:\DELETEME\StarterProject>spatial diagnose
JAVA_HOME environment variable
[SUCCESS]
- The ‘JAVA_HOME’ environment variable points to a valid JDK installation.
- Installed at ‘C:\Program Files\Java\jdk1.8.0_131’.
Java Runtime Environment
[SUCCESS]
- Installed at ‘C:\ProgramData\Oracle\Java\javapath\java.exe
C:\Program Files\Java\jdk1.8.0_131\bin\java.exe’.
- Found version 1.8.0_131.
Java compiler
[SUCCESS]
- Installed at ‘C:\Program Files\Java\jdk1.8.0_131\bin\javac.exe’.
- Found version 1.8.0_131.
Microsoft Visual C++ (MSVC) Redistributable
[SUCCESS]
- Found version 14.10.25008.
Network access
[SUCCESS]a-
- All checks passed
- Installed at ‘C:\ProgramData\chocolatey\bin\spatial.exe’.
Project SpatialOS SDK version
[SUCCESS]
- Found version 10.3.2.
Spatial SDK command-line plugin
[SUCCESS]
- Installed at ‘C:\Users\kenny.doerhoff\AppData\Local.improbable\bin\plugins\sdk\10.3.2\sdk.exe’.
- Found version 10.3.2.
Spatial global command-line tool
[SUCCESS]alOS/
- Installed at ‘C:\ProgramData\chocolatey\bin\spatial.exe’.
- Found version 20170525.113401.
sbt
[SUCCESS]|
- Installed at ‘C:\Program Files (x86)\sbt\bin\sbt
C:\Program Files (x86)\sbt\bin\sbt.bat’.
- Found version 0.13.13.0.
unity
[SUCCESS]
- Installed at ‘C:\Program Files\Unity\Editor\Unity.exe’.
- Found version 5.6.0.
[RESULT] All diagnostic tests passed successfully.
‘spatial.exe diagnose’ succeeded (14.5s)

No issues found…

I tired uninstalling and reinstalling Unity3d, Spatial and Java with no love…

Just still kind of confused what to try next. It is prob something simple that I over looked but I can not seem to find it.

This is a laptop not my main computer thank good… I will be installing it on one more computer at home (A huge 32 core Server beast that we plan on using for builds) Just hoping I do not have the same issue on it…