Improbable Icon

Cannot compile Wizards

general

#1

Hi, I have Unity 5.5.4, 5.6.1 and 2017 beta.

Apart from an annoying bug that freezed the console randomly after:

  • Build the project: spatial worker build
    …and having to input Enter key, which took me 52 minutes to figure out, the build failed:

Platform assembly: C:\Program Files\Unity\Editor\Data\Managed\Unity.IvyParser.dll (this message is harmless) SpatialOS SDK: You are using an unsupported version of Unity. The currently supported versions are 5.5.3/5.6.0. ApplicationException: Failed to build player WorkerType=UnityClient;BuildTarget=StandaloneOSXIntel64;EmbedAssets=False;BuildOptions=None due to Building a player for ‘Mac’ (27) target is not supported in this Unity build.

So I tried SpatialOS, read the documentation and several pages. And the result is that I filled two bugs here X_X


#3

Hey there,

Looking at the error:

Failed to build player WorkerType=UnityClient;BuildTarget=StandaloneOSXIntel64;EmbedAssets=False;BuildOptions=None due to Building a player for ‘Mac’ (27) target is not supported in this Unity build.

Just checking: Did you remember to install the MacOS build tools and Linux build tools as part of your Unity installation?