Improbable Icon

Forums

Can't run starter project


#1

I’m trying to get the starter project up and running, but when I hit the Start button to start SpatialOS, I get the following:

Generating bridge settings for UnrealClient.
Generating bridge settings for UnrealWorker.
Generating managed worker configuration for UnrealWorker.
‘spatial worker build build-config’ succeeded (0.0s)
Transferred 33.1MiB/ 73.3MiB [========= ] 45% [0.6MiB/s]

It gets up to 36.2 MiB, and then every time it errors out like so:

Could not download the JRE, attempting to use the system’s installed JRE. failed to retrieve worker package: rpc error: code = DeadlineExceeded desc = context deadline exceeded
Preparing to run SpatialOS.
C:\Projects\SpatialOS\UnrealGDKStarterProject\spatial\schema/unreal/gdk/spawndata.schema:4:1: Couldn’t read imported file ‘improbable/vector3.schema’.
C:\Projects\SpatialOS\UnrealGDKStarterProject\spatial\schema/unreal/gdk/spawndata.schema:4:1: …while processing imported file ‘improbable/vector3.schema’.
Error during command execution: exit status 1 ] 50% [0.6MiB/s]
‘spatial prepare-for-run’ failed (0.3s)
Encountered an error during command execution.
exit status 1
Press any key to continue . . .

I tried switching to a different ISP, but still the same. Any ideas?


#3

Solved it. I saw that there were log files in the spatial folder, so I opened one of them and found the URL it was using to download the JRE. Pasted that into my browser and it downloaded fine. Renamed to jre-win64.zip and moved it to the folder where the log file said it was looking for it.

At that point I was still getting the vector3.schema error, so I went into VS and cleaned the project and then built it. It works now.


#4

Hey @creo,

great to hear you’ve solved it and thanks for sharing, good info for anyone else who might come across the same error. :slightly_smiling_face:

Cheers!

Nee