Improbable Icon

SpatialOS Discourse Forums

Could not find spatial

Could not find spatial. Please make sure you have it installed and the containing directory added to PATH environment variable

how do I fix this?
Yes I have installed the spatial OS launcher, but the PATH Variable was not set. How would I set it?

Hi @Squee-Z
Welcome to the community :slight_smile:
Please see these guide on how to set your PATH:


I still get the error. sorry, I just have no detail on what’s going on.

Hi @Squee-Z,

Could you help check if you have the following folder exists and also added into path?
C:\Users<user name>.improbable


I figured it out. I had to edit the bat file because it didn’t know the command ‘where’ so it wasn’t able to locate spatial. So i removed the ‘where’ command check and it worked. Thank you for helping though!

Hi @Squee-Z,

Glad to hear the issue has been resolved.
Let me know if you need any further help.

I’m trying to build lighting for one of my levels, and it says that there is two world settings and it can’t build swarm connections because there is a spatialworldsettings and ue4’s worldsettings. Can I remove this world setting? will it harm me deploying? and how do I fix this? Thank you!

Hi @Squee-Z,

For the Spatial Project, you should use the SpatialWorldSettings - this class inherits the UE4 WorldSettings so it have all the same functionality, and it contains load balancing settings and locking policy options.