Improbable Icon

SpatialOS Discourse Forums

Error during building my project

Hello everyone,

I am trying to build my project using the starter template. After following the guide posted in SpatialOS Docs, I ended up with an error.

After starting BuildProject, it asks for paths of the files locations “directory”, and spend couple of minutes building workers. Following that, it ends with the following error:

********** STAGE COMMAND COMPLETED **********
********** PACKAGE COMMAND STARTED **********
********** PACKAGE COMMAND COMPLETED **********
BUILD SUCCESSFUL
AutomationTool exiting with ExitCode=0 (Success)
Invalid number of parameters
Exit code 4 while running:
xcopy
/I
/Y
C:\Unreal\UnrealEngine\Engine\Plugins\UnrealGDK\SpatialGDK\Binaries\ThirdParty\Improbable\Programs\WorkerCoordinator
F:\Unreal_Creation\SpatialOS\build two\randomtrial\spatial\build\unreal\LinuxNoEditor
Builds failed.
Press any key to continue . . .

I really wish someone can help me with that, i’ll be very thankful, and my heart will be filled with both joy and entertainment :stuck_out_tongue:

Game engine: Unreal engine 4
+

thanks in advance everyone for either the time that you spent reading this, or helping me out ^_^.

Hi @Alhatem

Sorry to hear you’re having trouble.

Can you just confirm for me that you’ve installed all of the dependencies covered here:

In particular, have you installed the Linux Cross Compilation toolchain indicated at the very bottom of the page?

Thanks for the quick reply, yes I did.

In fact, I was able to deploy “The Example Project”# succesfully, but not the starter template sadly >.<.

Also, I tried running the following command:

%LINUX_MULTIARCH_ROOT%x86_64-unknown-linux-gnu\bin\clang++ -v

and I got the following result:

as well as verifying the environment variable:
image

both of them seemed to me ok.

Hello,

I see your project is in a directory named “build two”. Could you try renaming that to “build_two”? Sometimes spaces in the path can mess some scripts up.

1 Like

Hello,

thanks for replying, I followed your instructions and it did fix the issue successfully.

Solution for future reference:
I had to change the file’s names(directory) so that it does not include any spaces at all.

example:
F:\Unreal_Creation\SpatialOS\build two\randomtrial\spatial\build\unreal\LinuxNoEditor
changed to:
F:\Unreal_Creation\SpatialOS\build_two\randomtrial\spatial\build\unreal\LinuxNoEditor

“build two --> build_two”

However, I am encountering another issue unfortunately.

Everything is built correctly, and no errors at all, but for some reason when I launch the game it loads without errors, following that it shows black screen? I tried launching the game on my other desktop/laptop same issue… black screen… :frowning:

any idea?

again, thanks!!!

Hey @Alhatem,

Good to hear your other issue is resolved!

For this black screen issue could you check that you are using the deploy button in the editor that the launch configuration file is set to one_worker_test.json instead of default_launch.json for me?

Kind regards

Kieran

1 Like

and that resolved the issue!

Thank you for the support !!
I really do appreciate it!!
it’s time to grind I guess… :stuck_out_tongue: