Improbable Icon

SpatialOS Discourse Forums

Error - Generating Schema / Full Scan

Hello everyone,

I am trying to generate a “schema” (full scan and incremental) after creating multiple levels in my project but the process kept failing.
What I am trying to do is:
Create multiple levels (main-menu, travel/trans, lobby, and arena levels) so that the user is introduced to the main menu first and he has the option to join the lobby/arena levels or not.

As soon as, I created those and changes some settings on project settings, I couldn’t generate schema at all. I tried to reverse back step by step, nothing worked sadly.

I wish I can provide with error log, but I have no idea where to find it…
it just states that:
image

I tried generating schema using cmd using this command:
<Path to your game’s .uproject file> -run=GenerateSchemaAndSnapshots -MapPaths=<MapName1;MapName2;MapName3>

But it didn’t work :frowning:

Game Engine: Unreal Engine 4

Thank you, thank you, in advance!!

Hey @Alhatem,

Would you be able to provide us with what project settings were changed? Also have you fully reverted to the original settings?

Secondly if you can look at the output.log when running this (found in the editor to the right of the Content Browser tab) and provide us with what errors are located there?

Kind regards

Kieran

1 Like

Hello,

Thanks for the reply, I was able to fix the error by following the output.log instructions.

The issue was very simple, one of the characters blueprint’s names included numbers, and that is not supported according to the output log:

Solution:

Thus, All what I had to do is to change my character’s blueprint name to something else that doesn’t include numbers/special characters.

Again, thanks @Keiran for showing me how to get the output.log.

Note:
if Output.log not shown, go to Window > Developer tools > Output Log.

Again, Thank you.

Awesome!

Glad this got fixed for you!

Feel free to post again if a new issues crops up!

1 Like