Improbable Icon

Got some errors when deploying the project locally


#1

Hello
I am learning the tutorial https://docs.improbable.io/unreal/alpha/content/get-started/tutorial#deploy-the-project-locally. When I click the Launch button in the SpatialOS GDK toolbar, I got some errors below, but it shows SpatialOS is ready, I don’t know whether it is ok or not.

Generating bridge settings for UnrealClient.
Generating bridge settings for UnrealWorker.
Generating managed worker configuration for UnrealWorker.
'spatial worker build build-config' succeeded (0.0s)
Preparing to run SpatialOS.
No changes detected, skipping code generation.
'spatial prepare-for-run' succeeded (0.3s)
SpatialOS will launch from snapshot file 'B:\Documents\Work\git\UnrealGDKThirdPersonShooter\spatial\snapshots\default.snapshot'.
Error retrieving: https://commondatastorage.googleapis.com/improbable-webtools/beast/2018-11-01-1644-395b88d/maryjane/css/console.css on attempt 1 of 5: code = Unknown desc = Error on request to: https://commondatastorage.googleapis.com/improbable-webtools/beast/2018-11-01-1644-395b88d/maryjane/css/console.css
Error retrieving: https://commondatastorage.googleapis.com/improbable-webtools/beast/2018-11-01-1644-395b88d/maryjane/css/console.css on attempt 2 of 5: code = Unknown desc = Error on request to: https://commondatastorage.googleapis.com/improbable-webtools/beast/2018-11-01-1644-395b88d/maryjane/css/console.css
Error retrieving: https://commondatastorage.googleapis.com/improbable-webtools/beast/2018-11-01-1644-395b88d/maryjane/css/console.css on attempt 3 of 5: code = Unknown desc = Error on request to: https://commondatastorage.googleapis.com/improbable-webtools/beast/2018-11-01-1644-395b88d/maryjane/css/console.css
Error retrieving: https://commondatastorage.googleapis.com/improbable-webtools/beast/2018-11-01-1644-395b88d/maryjane/css/console.css on attempt 4 of 5: code = Unknown desc = Error on request to: https://commondatastorage.googleapis.com/improbable-webtools/beast/2018-11-01-1644-395b88d/maryjane/css/console.css
Error retrieving: https://commondatastorage.googleapis.com/improbable-webtools/beast/2018-11-01-1644-395b88d/maryjane/css/console.css on attempt 5 of 5: code = Unknown desc = Error on request to: https://commondatastorage.googleapis.com/improbable-webtools/beast/2018-11-01-1644-395b88d/maryjane/css/console.css
[Inspector]: code = Unknown desc = Failed to fetch assets: code = Unknown desc = Failed to fetch asset: console.css
SpatialOS starting.
Downloading new SpatialOS Runtime version 11-20181026T095601Z-a3b2bcf...
Transferred  81.6MiB/ 81.6MiB    [====================] 100% [8.5MiB/s]]
Extracted SpatialOS Runtime to C:\Users\nani\AppData\Local\Temp\fabric_bundles\11-20181026T095601Z-a3b2bcf.
master node elected with ip(127.0.0.1) current node ip(127.0.0.1)
fetched java params from etcd
fabric classpath size: 3
user classpath size: 0
[improbable.worker.assembly.WorkerAssemblyProviderFactory] Loaded worker assemblies for these workers types: UnrealClient, UnrealWorker.
[improbable.worker.assembly.WorkerAssemblyProvider] The following worker configurations do not contain valid managed launch configurations for the current platform WINDOWS, and the runtime will be unable to launch managed workers of this type: [UnrealClient]. This is expected for worker types you intend to only connect manually.
[improbable.module.ModuleNode] Loading snapshot.
[improbable.persistence.snapshot.SnapshotLoader] Loaded 38 entities from snapshot, waiting for all of them to be created.
[improbable.module.ModuleNode] Snapshot has been successfully loaded in 0.14s.
[improbable.module.ModuleNode] SpatialOS runtime startup complete.
SpatialOS ready. Access the inspector at http://localhost:21000/inspector (31.1s)

#3

It’s ok if you just run the game. If you want to access the local inspector, you may have a problem because it didn’t seem to be downloaded properly. (it’s located at C:\Users{UserName}\AppData\Local.improbable\local_inspector)

I had the same problem, so I guess you are in China too. You’ll need a VPN to access *.googleapis.com domain because it’s blocked by GFW. I’m using a web proxy so my approach is to set the “https_proxy” environment variable. You can find more instructions here:
https://docs.cloudfoundry.org/cf-cli/http-proxy.html


#4

I have the same error, and the shooter demo dont works well, some times the client 2 dont have any weapons, sometimes both dont have any weapons, its really unstable.


#5

How often do the weapons not appear?


#6

It’s random, but I managed to get the 2 customers with weapons 1 time out of 10.