Improbable Icon

Java version 9.0.1 error on set up

general

#1

SpatialOS SDK versions installed locally: 12.0.1.
with JDK 9 version
gives an error when you try to build a game, experienced for the Wizards and Pirates tutorial.

Had to run /usr/libexec/java_home -V,
then run export JAVA_HOME=/usr/libexec/java_home -v 1.8.0_151
and exclude the JDK from being picked by default by renaming its Contents/Info.plist to Info.plist.disabled


#3

Hello @musutou!

Welcome to the forums. :slight_smile: As specified in the System Requirements page SpatialOS currently requires to use Java 8.

The use of JAVA_HOME is indeed the way you should deal with a dual-JDK installation to manage the different versions.

Best regards,
Duco