Improbable Icon

Not working with Unity 2017.2

unity
support

#1

Hi.

After trying out Lazarus I got curious about what SpatialOS was and after looking through your documentation and some of your videos I got more and more intrigued.
But after installing the Spatial software and launcher and downloaded the StarterProject following the guides it failed building.
Looking through the log I came across this exception:

ArgumentException: Scene file not found: ‘Assets\ClientScene.unity’.
at (wrapper managed-to-native) UnityEditor.SceneManagement.EditorSceneManager:INTERNAL_CALL_OpenScene (string,UnityEditor.SceneManagement.OpenSceneMode,UnityEngine.SceneManagement.Scene&)
at UnityEditor.SceneManagement.EditorSceneManager.OpenScene (System.String scenePath, OpenSceneMode mode) [0x00005] in C:\buildslave\unity\build\artifacts\generated\common\editor\EditorSceneManagerBindings.gen.cs:32
at Improbable.Unity.EditorTools.Build.SingleScenePlayerBuildEvents.GetScenes (WorkerPlatform workerType) [0x0000d] in C:\w\ee9378522cbb9fd1\UnitySdk\Improbable.Unity\Assets\Precompiled\Editor\Build\SingleScenePlayerBuildEvents.cs:53
at Improbable.Unity.EditorTools.Build.UnityPlayerBuilder.BuildPlayer () [0x00014] in C:\w\ee9378522cbb9fd1\UnitySdk\Improbable.Unity\Assets\Precompiled\Editor\Build\UnityPlayerBuilder.cs:171
at Improbable.Unity.EditorTools.Build.UnityPlayerBuilders.BuildPlayers (IList1 playerBuilders, IList1 selectedWorkerTypes, PlayerCompression compression) [0x0008d] in C:\w\ee9378522cbb9fd1\UnitySdk\Improbable.Unity\Assets\Precompiled\Editor\Build\UnityPlayerBuilders.cs:87
at Improbable.Unity.EditorTools.Build.UnityPlayerBuilders.BuildDeploymentPlayers (IList`1 selectedWorkerTypes) [0x00000] in C:\w\ee9378522cbb9fd1\UnitySdk\Improbable.Unity\Assets\Precompiled\Editor\Build\UnityPlayerBuilders.cs:57
at Improbable.Unity.EditorTools.Build.SimpleBuildSystem+c__AnonStorey4.<>m__E () [0x00000] in C:\w\ee9378522cbb9fd1\UnitySdk\Improbable.Unity\Assets\Precompiled\Editor\Build\SimpleBuildSystem.cs:188
at Improbable.Unity.EditorTools.Build.SimpleBuildSystem.RunIf (System.String targetName, System.Action action) [0x00038] in C:\w\ee9378522cbb9fd1\UnitySdk\Improbable.Unity\Assets\Precompiled\Editor\Build\SimpleBuildSystem.cs:246

There is no ClientScene.unity in the project, nor can I find any reference to that when searching through all the files.

I tried downloading the BlankProject and the Wizard demo as well, both of which suffered from the same problem.

Are there any fixes in the works?

I was really hoping to see what I could create with the help of SpatialOS.


#3

Hello @fuzzyhobo,

Welcome to the forums! Nice to see you found out about us through Lazarus. :slightly_smiling_face:

Even outside the scope of this particular issue, there are in general some reported issues with Unity 2017.2. We also do not officially support that Unity release yet. As per our requirements page we officially support 5.5.3 and 5.6.0. Unity 2017.1 appears to be working fine as well but we do not (yet) test against that during our release process.

Best regards,
Duco


#4

Unity 2017.2b8 also works; there has been a change in f3 that broke the WWWRequest class’ handling with SpatialOS.

Also: the error above is not something I encountered before with 2017.2; I wouldn’t be surprised if it isn’t related to 2017.2


#5

I tried downgrading to Unity 2017.1.2f1 and it’s still not working with the same exception…
I don’t know why it’s looking for ClientScene.unity since it doesn’t exist and I can’t find any file that references it


#6

Well, the file should have been in your starter project (see here: https://github.com/spatialos/StarterProject/tree/master/workers/unity/Assets/), could it be that you accidentally deleted it?


#7

As you can see in the repository you link yourself there is no ClientScene.unity, there is only UnityClient.unity and UnityWorker.unity


#8

At this commit the project renamed the scene files and a shot in the dark would be that somewhere in the spatial software there is still a hardcoded string


#9

Sorry, you are right; I got the names confused. Odd that you are running into this … I haven’t encountered this before


#10

I had a very similar issue where the Linux build’s asset database was not
being correctly assembled during deployment builds. The CoreSdk.so (if
memory serves) was not making it into the _Data file. When looking through
the local / cloud worker logs I saw a lot of path inconsistencies, I
thought this might be due to project running out of my E: drive instead of
C: drive.

But I couldn’t nail down the exact causes so I just ran through the
installation checklist real quick:

  • Performed a clean install of Unity-5.6.0f3, making sure linux and mac
    build support was enabled
  • Verified UNITY_HOME environment variable was correctly referencing my
    C:/Program Files/Unity-5.6.0f3 installation.
  • Clean pull of StarterProject repo @ 12.0.4
  • Performed build steps as described in the 12.0 getting started tour

Works like a charm now!

If you think it would help, I can upload some logs so we can
cross-reference our findings?


#11

Hi @fuzzyhobo,

Sorry to hear that you are having issues. You error is quite puzzling and I’m not being able to reproduce, but I have some ideas, well actually, are pretty much what scripts52 pointed out.

You said that you installed Unity 2017.1, but you might still have UNITY_HOME referencing 2017.2, so checking that would be my 1st attempt.

Also, check that you installed the Linux and Mac support for Unity.

Kind regards,
David


#12

Really weird.
I don’t know what the issue was but after rebooting and downgrading to 5.6 I got it working, and it’s even working when I upgrade to 2017.1.

Thanks for all the help.