Improbable Icon

SpatialOS Discourse Forums

Please keep up with Current Game Engine Builds

I tested your service some time ago. And even then you were far behind the Game Engine builds that were current. Unreal Version 4.24 is Quite Amazing in it’s feature set and I see no reason to reduce the quality of my games in order to use SpatialOS. Knowing your Company’s Budget, I see know reason that you can not afford to hire extra staff to keep current. I mentioned this a couple of years ago and it still is an issue. Once again I ask you to correct this.


I hear you! I feel the same. It is the primary reason why I don’t bother with improbable…

So when I saw there is a 4.24 repo available I jumped back on the bandwagon and downloaded that. It was last updated in December but still, it’s 4.24 :slight_smile:

Unfortunately it has still taken me days to get setup (and I am still busy trying to get setup…)
At the moment the GDK can’t build because they only support VS 2017 but I just found a workaround for that by opening up FindMSBuild.bat and just hardcoding the path to my VS 2019 MSBuild and now setup just completed. Now to see what the next challenge is to getting started…

As much a I prefer Unreal to Unity I think with Unity I would have been up andrunning in half an hour. So far it’s taken me over a week to get the UE4 version setup…

But at least it’s 4.24 :smiley: So I keep going… HopefullIy will get there eventually. At least I managed to get UE4 built before I downloaded the GDK so now I just need to get that part integrated and then hopefully all will be well… Touch wood

1 Like

Nope… Can’t build the GDK because their code is complaining that

e:\GitHUB\Improbable424\Engine\Plugins\UnrealGDK\SpatialGDK\Source\SpatialGDK\SpatialGDK.Build.cs(51,17) : error CS0151: A switch expression or case label must be a bool, char, string, integral, enum, or corresponding nullable type

I am trying to see what the problem is with the enum but the fie that the error is being reported in does not exist. I really don’t want to waste a month of my life getting their installers to work…

Still just as useless as ever… :frowning:

As I said… I share your frustration

Hi @EddieChristian, thanks for your feedback on this, it’s always good to get thoughts from our dev community and we do take everything into consideration.

We try and keep as updated with the latest versions of the engines as we possible can but we also want to make sure that we have SpatialOS working to the best level possible and that we can support developers as well. Currently, our release branch supports 4.22 and our preview branch supports 4.22 and 4.23 and we’re working to support versions beyond that (you can also read about our branches here). We appreciate everyone’s patience when working with newer versions, but from our perspective, we want to make sure we have a effective working product and technical support available to help our devs.

@Ryunosuke-Jansen - I’m sorry to hear that you’re encountering this error. It would be helpful if you could post in the Support section of these Forums and we can check out what the issue is and help you as best as we can.


Hi Nee

The OP speaks of updating to latest versions of UE4 and that I understand is probably much to expect but why in the world can you not at least support VS2019? That is my problem I think.

I tried to build the engine again after the batch file failed and VS allowed me to find the file that was mistakenly reported at a different location. It turns out I had to manually find the vales of the platform names and change the values you used in that switch into strings and that finally allowed the build to continue but after about an hour it failed with 84 errors relating to all manner of stuff

So TLDR version: DL the fork, build, enjoy without support for your platform. Add GDK, building now fails, start the 20Gb download process all over again.

Not really an appealing prospect. Neither is installing VS 2017 just for you when 2019 works just fine for everything else.

Why can’t you just support the latest VS at least? Surely THAT isn’t too much to ask, is it?

Hi @Ryunosuke-Jansen,

VS 2019 is supported on our preview branch, as per our preview docs here - which help outline some dependencies when getting started with the preview branch. Hope that helps.


As a 5 Star Developer for the Unity Store, I can tell you that one of the ways I keep my rating is to make sure I have a working build for the latest version of Unity within 2 weeks of a build release. So if I can achieve this as a single person, I know it is possible for a team of people to achieve the same thing. I am hopefully going to be using your product in both Unity and Unreal, But I need to know that keeping things current is your Top Priority.

Agreed, how can I use a product that doesnt even work.

Hi Dee. Thanks for pointing me to that link. I downgraded as instructed but even so it made no difference. The link you sent me to clearly states “This is old. Go here instead” and the other page states very clearly “Use 2017. Anything else won’t work”. Well, see for yourself.

If this is a case of the GDK only working on certain branches, well then that is a serious problem…

Sorry, just to clarify… I downgraded .net as instructed under the 2019-specific instructions.

I have wasted a very large percentage of my metered data on downloading the insane number of Gigs to try and try your product and after all this time spent just trying to get up and running I am still left with a product that can’t be compiled and have thus wasted my time and data allocation for absolutely nothing.

Might I request SOME means in future to get ANY fork (not to be told “We recommend getting UE4 from 2 years ago but the one from last year is stable also. If you want to use your version of VS then please use the most unstable version there is from X years ago. Use the latest one but be aware it doesn’t work at all”) and some way of making it work with your product?

It sounds crazy to have to ask someone “Could you please give me a way to make your product work” but this is where we are at. There is a fork for the version I want and yet there is no way to get it working with the latest version of Visual Studio so the only way to use your product is to downgrade my development environment (seemingly required no matter what) or to get an outdated version of UE4. What does that say about your tools? In addition, I don’t see how my version of VS can explain errors about overriding functions not overriding anything or methods/members of a class not existing within the class it is being called with…

Clearly there is a code problem and for me to have to spend days trying to get your product up and running and then to run into these type of errors… again, what is that saying about you? I have been a big fan of what you are offering and been so for a long time and yet I don’t use you for the plain and simple reason that I simply can’t… So I repeat my request: “Can you please make it possible for me to use your product?”

VS2019 using the 4.24 branch… can you make that happen before 4.26 is released?

I think they do a decent job of keeping up considering they dont know what the code is until we do I presume. Maybe as time goes on and they get even closer with the Unreal team it could be all realised at the same time.