Improbable Icon

[RESOLVED] Internal Server Error on Authentication

v9-0-0

#1

Hi,

When I run any command in the console (e.g. spatial local start or spatial codegen), SpatialOS wants to validate through the browser. However, when it attempts to do so, I see an Internal Server Error. Well, actually, I see what I have posted at the bottom of this post.

The authentication eventually does come through, albeit with a delay, but it will prompt again for authentication on the next command and get a new Internal Server Error.

{}


<html>
<head>
    <title>
    Error: Internal Server Error
</title>
    <link href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.4/css/bootstrap.css" rel="stylesheet">
    <link href="https://cdn.rawgit.com/lipis/bootstrap-social/gh-pages/bootstrap-social.css" rel="stylesheet">
    <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css">
    <link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Cabin:400,400italic,700|Ropa+Sans" type="text/css">
    <link href="https://storage.googleapis.com/improbable-static/css/improbable-bootstrap-theme-1.1.css" rel="stylesheet">

    
<style>
body {
  margin-bottom:60px;
  background-color: #eee;
  font-family: "Cabin", Arial, sans-serif;
  overflow
}

  .improbable-logo {
    border: 3px solid black;
    display: block;
    height: 29px;
    margin-top: 10px;
    position: relative;
    width: 29px;
  }

  .improbable-logo::before {
    background-color: black;
    content: "";
    display: block;
    height: 11px;
    left: 10px;
    position: absolute;
    top: 6px;
    width: 3px;
  }

  .improbable-logo::after {
    border: 1px solid black;
    border-radius: 50%;
    content: "";
    display: block;
    height: 4px;
    position: absolute;
    right: 1px;
    top: 1px;
    width: 4px;
  }

.form-signin {
  display: table;
  padding: 15px;
  min-height: calc(100vh - 110px);
  text-align: center;
  vertical-align: middle;
  width: 100%;
}

  .form-signin-content {
    display: table-cell;
    vertical-align: middle;
  }

  .form-signin .panel {
    margin: 0 auto;
    max-width: 320px;
  }

.form-signin .form-signin-heading,
.form-signin .checkbox {
  margin-bottom: 10px;
}
  .form-signin-heading {
    font-family: "Ropa Sans", "Cabin", sans-serif;
    font-weight: normal;
    text-transform: uppercase;
  }

.form-signin .checkbox {
  font-weight: normal;
}
.form-signin .form-control {
  position: relative;
  height: auto;
  -webkit-box-sizing: border-box;
     -moz-box-sizing: border-box;
          box-sizing: border-box;
  padding: 10px;
  font-size: 16px;
}
.form-signin .form-control:focus {
  z-index: 2;
}

.btn-margin  { margin: 5px; }


   
  html {
  position: relative;
  min-height: 100%;
  overflow:auto;
  }

  .footer {
  position: fixed;
  bottom: 0;
  width: 100%;
   
  height: 60px;
  background-color: #f5f5f5;
  line-height: 60px;
  }

</style>

</head>
<body>
    

<header class="navbar navbar-default">
    <div class="container-fluid">
        <ul class="nav navbar-nav">
            <li>
                <span class="improbable-logo"></span>
            </li>
            <li id="menu-item-10">
                <a href="https://console.improbable.io/">Home</a>
            </li>
        </ul>
</header>

<div class="container-fluid main">
    <div class="alert alert-danger page-header" role="alert">
        <h4>
            Internal Server Error
            (500)
        </h4>
        <p>
            
            <strong>Details: </strong>Something went wrong<br />
            
            
            <strong>Request ID: </strong>b0KkOGmrQXuvOOVApCQAqg==<br />
            
            
            <strong>Type: </strong>https://godoc.org/google.golang.org/grpc/codes<br />
            
        </p>
    </div>
</div>


<footer class="footer">
    <div class="container-fluid">
        <p class="text-muted">Copyright © 2016  Improbable Worlds Ltd.</p>
    </div>
</footer>

<style>
</style>



</body>
</html>

#2

Hello @DeBock,

Sorry for your trouble. Could you please indicate what browser you are using that generates the error your experience?
And do you literally see the content you posted in your code snippet?

Best regards,
Duco


#3

Hi @dvanamst

Thanks for responding.

I am using Chrome Version 55.0.2883.87 on a Windows 10 laptop, and yes that is literally the shown output to me, NOT the source code for the page (which it clearly also is though).


#4

Did you experience similar issues when running other spatial commands like spatial update?

I’m trying to find the common denominator of what’s going on as the environment you are using should work without any issues.


#5

It also occurs with spatial update, yes.

Note that it is only an inconvenience, it does eventually go through, although with the following text in yellow:

Could not generate update to date deployment config, trying to use cached one

I’m not sure what that means though.

Also please note that this only started occuring today, yesterday I did not have this issue.


#6

Oh spatial update actually failed completely, I got the following feedback:

C:\Users\Rami\Documents\BlankProject-spatialOS3>spatial update
Current version: 20170131.164947.d3edeaf
Attempting to download latest version for platform win.
Visiting url: https://auth.improbable.io/auth/v1/authorize?client_id=improbable_cli_client_go&redirect_uri=http%3A%2F%2Flocalhost%3A12000%2Fauthcode&response_type=code&scope=%5B%2A%5D%3A%2A
Version: 20170131.164947.d3edeaf
At 2017-02-07 09:48:01 UTC failed executing command:
    spatial update
Version: 20170131.164947.d3edeaf
could not obtain auth token: code = Unauthenticated desc = failed obtaining new refresh token: code = Unknown desc = failed obtaining AuthCode: code = DeadlineExceeded desc = timed out waiting for user to click the auth link
failed obtaining new refresh token: code = Unknown desc = failed obtaining AuthCode: code = DeadlineExceeded desc = timed out waiting for user to click the auth link
failed obtaining AuthCode: code = DeadlineExceeded desc = timed out waiting for user to click the auth link
timed out waiting for user to click the auth link

I tried updating to Chrome 56, but no change.


#7

Regarding this last error: did your browser still open automatically a new tab for authentication?

From what I get from the output it either did not open op the browser-tab automatically or you did not provide authentication within the popped-up one before time-out.


#8

It opened a new browser tab with the “internal server error” HTML/CSS output earlier provided. Appears to be the exact same output.


#9

Before I pass this one to the people maintaining that part of our platform could you try logging out and in again on https://spatialos.improbable.io/?

Making sure that it has nothing to do with some kind of half-expired authentication token. :slight_smile:


#10

Yeah so the thing is, when I click “Sign In” (top right corner) on the page you linked, I get the exact same ‘internal server error’ output in my browser. So… No can do?


#11

I’ll consult as soon as possible with the people who maintain this but for the moment it does look like this is local to your installation. We’ll try to help you out in the best possible way.


#12

This issue appears to have resolved, at least for now.


#13

Thank you very much for reporting this. The underlying issue for you initial authentication error should indeed be resolved by now.