Improbable Icon

Spatial

unity

#1

I am not at all able to run Spatial Diagnose for the setting up Pirates Tutorial.

What I am doing wrong ?
Help me out I have already used 2 days time but can not resolve it.

Default spatialos.json
1537960333982-SpatialOS.Launcher.log (2.5 KB)

Changed spatialos.json version number
1537960835811-SpatialOS.Launcher.log (2.5 KB)


#3

@Aviral_Bharadwaj Could you do a spatial diagnose --log_level=debug and post the debug logs please.it should locate in the log folder. it should create 3 log files everytime you run this command. I can’t really see any debug information from the log you posted. Btw, make sure you run this under your project folder.


#4

1537970561907-SpatialOS.Launcher.log (2.5 KB)

I am only seeing one log file. Which is from the log folder only.

This is the debug from the console.
The sdk cannot be located. Do we need to change the location ?


#5

@Aviral_Bharadwaj

Sorry for the issues you’re having,

From the detail of your screenshots its not clear what’s happening, also the logs you sent are for the SpatialOS Launcher and are not related to the CLI Tool.

We need the logs contained in the PiratesTutorial folder here PiratesTutorial-master\logs

For our own information while debugging this issue,

Can you please confirm you have run through the entire setup for Windows here:
https://docs.improbable.io/reference/latest/shared/get-started/setup/win

And that the pirates version you downloaded has is - https://github.com/spatialos/PiratesTutorial and you’ve not edited/changed any files

Please ensure you’ve the latest Spatial CLI version run command spatial update then spatial version you should see 20180925.122635.0894c10a06 (note the update will be approx. 60mb)

Then please try to re-run spatial diagnose from the root of the Piratestutorial repo and copy the full terminal output


#6

I am attaching the logs from Pirate Ship tutorial only this time.
Yes, I have followed ever thing in detail but still no luck for me.
I am using 13.2 and the latest Spatial CLI.

spatial_20180928T003340.log (5.1 KB)


#7

Hey, @Aviral_Bharadwaj could you try to ping api.spatial.improbable.io ? This is API for package service you are not able to reach based on the log you sent to us. It could blocked by your firewall or get timed out due to the poor network connection.


#8

@Stan I can ping it and is working fine. There is no packet loss at all.
I have even tried after turning off firewall still not working yet. I will still try once more as you described the issue is also related too.