Improbable Icon

Support for Unity 2017.1.0


#1

Tried the Pirates Tutorial. When I run spatial diagnose it reports a failure:

unity
[FAIL]atialO/

  • The installed version (2017.1.0) of Unity is not supported. The recommended version is 5.6.0.

This is the current stable release of Unity.


#3

Until then the workaround is to downgrade Unity3D:

  • Uninstall Unity manually
  • Open an administrator command prompt
  • Navigate to your project folder
  • Run spatial setup install-dependencies to install the supported Unity3D version (it is 5.6.0 at the time of writing)

It might take 20+ minutes, even with a fast network connection.


#4

Hello @Viktor,

The observations that you describe are actually what is expected if you try running with 2017.1.0.

As per the system requirements we do not support by default support the latest Unity release in combination with SpatialOS. For each new Unity release that contains breaking changes we need to do a new release of our Unity integration with the necessary modifications hence there is some lag between the Unity release and SpatialOS supporting it.

With respect to the 20+ minute setup this is also expected and the output of the spatial setup install-dependencies actually suggests that it might take a while to complete. We are entirely dependent here on the size of Unity binaries.

Do please give your feedback so that we can see where we can be of the most help to you, and provide the most effective improvements to your experience as a developer. :slight_smile:

Best regards,
Duco