Improbable Icon

Trouble Launching Cloud Deployment

I have been following the GDK for Unreal Example Guide, and am currently stuck at step 3.5 (Sample Projects > Example Project > 3. Launch a cloud deployment > Step 5: Launch your cloud deployment).
When I try and deploy via DeployGame.bat, I encounter the error required flag(s) “runtime_version” not set. Unfortunately I am fairly new to CLI and can’t seem to figure out how to set the runtime version.
When using Unreal Editor, I select Deploy as per instruction in the documentation, and encounter the initial dialogue box. When Launch Deployment is clicked, the following second dialogue box comes up, and I’m not entirely sure what is wrong or if it is related to the CLI error. Finally, the console window does not launch. I’ve also tried following the YouTube video tutorials and redoing some steps, including re-running the BuildProject.bat. Not sure if it’s worth noting but it works perfectly fine locally.

Spacial CLI Version: 20200622.093857.47fbb22e5c
Project Name: beta_thirteen_salami_921
Assembly Name: exampleprojectassembly; gdkshooter2020-06-24; Beta-13-Salami (I have multiple of the same, was testing and re-trying different steps)

Thank you very much for the help! I suspect that I’m missing something obvious…

Hi @nashevch,

So it looks like these are two separate issues you’re running into.

Firstly, I’ve checked the repo and it looks like the DeployGame.bat is out of date and missing the mandatory runtime_version parameter.

You can ammend line 17 to the following to get this to work for you:

spatial cloud launch %deploymentname% one_worker_test.json %deploymentname% --snapshot=snapshots/default.snapshot --cluster_region=eu --runtime_version=14.5.1 || goto :error

https://github.com/improbableio/UnrealEngine/blob/4.24-SpatialOSUnrealGDK-release/Templates/TP_SpatialGDK/spatial-resources/DeployGame.bat

Secondly, that pop up is just informing you that based on the current launch configuration, the worker named DeploymentManager will not be started. This should be fine for testing out your game.
If you click “Yes”, are you able to launch successfully?

For your information, using the Editor to launch the deployments is the preferred flow.
I will also let the team know that the DeployGame.bat script is out of date and get them to fix it.

Let me know if those solutions don’t work out for you! :slight_smile:

1 Like

Thank you so much for the speedy reply and for your patience! :slight_smile:

If I click “Yes”, the Cloud Deployment dialogue minimizes itself and returns to the Unreal window, and the console window doesn’t launch. Nothing else happens, and no further progress is made.
The update to the DeployGame.bat has it running well and without errors, but it does not create a deployment for my project as I had anticipated.

Hi @nashevch, would you be able to post the CLI output from running the DeployGame.bat script?

It looks like the script hasn’t finished running. You should see either Deployment succeeded or Deployment failed.

As a temporary workaround, you can manually launch a deployment using the command below from the spatial directory of your project. Make sure to match up the <assembly_name> to what has already been uploaded. You’ll also need to choose a <deployment_name> which must be between 2-32 characters and only contain lowercase letters, numbers and underscores.

spatial cloud launch <deployment_name> one_worker_test.json <assembly_name> --snapshot=snapshots/default.snapshot --cluster_region=eu --runtime_version=14.5.1

I’ve taken a look at your assemblies and I’ve noticed that there are some upper-case letters and hypens in them. These are illegal characters in the deployment name field and may have been the cause of any launch failures.

I’ll do some investigation on our side to see if a lack of validation in the deployment manager is the issue.

Ahh sorry, I deleted my comment because I realized it wasn’t finished, but your comment was very helpful, thank you! I think the characters were definitely part of the issue. Much appreciated.

Generating bridge settings for DeploymentManager.
Generating bridge settings for SimulatedPlayerCoordinator.
Generating managed worker configuration for SimulatedPlayerCoordinator.
Generating bridge settings for UnrealClient.
Generating bridge settings for UnrealWorker.
Generating managed worker configuration for UnrealWorker.
‘spatial build build-config’ succeeded (0.0s)
Generating descriptor. 1/1 [====================] 100%
‘spatial prepare-for-run’ succeeded (4.0s)
Reusing assembly name ‘gdkshooter2020-06-24’ that is already in use. Overwriting the existing assembly.
Cleaning up worker configurations 4/4 [====================] 100%
Batch uploading worker configurations 1/1 [====================] 100%
Uploading artifacts [====================] 100%

Upload report:

  • 3 artifacts unchanged

Encountered an error during command execution.
cannot upload snapshot
Could not create History(gdkshooter2020-06-24) for Project(beta_thirteen_salami_921)
invalid field Name: value ‘gdkshooter2020-06-24’ must be a string conforming to regex “^[a-z0-9_]{2,32}$”
Deployment failed.
Press any key to continue . . .

I just took out the part of the DeployGame that added the date to the end of the project name, and looks like it deployed successfully. Thanks again.

Just wanted to add something interesting- even upon removing the instances of illegal characters, the command prompt and deployment still are not running from the Editor. I will try and poke around with it though.

Great news! I’ll let the team know there’s a validation or error message surfacing issue in the editor.

If you could find out anything else for that it would be much appreciated.

1 Like