Improbable Icon

UE4 / SpatialOS Third Person Starter Project


#1

I am wandering what kind / if any interest there is in having a Third Person Starter Project for UE4 & SpatialOS. If the demand is there I will take the time and whip together a little something and toss it on github. As it seems alot of peoples questions on Discord seem to relate to doing just this.

This would entail changing the camera angle to be behind the back (third person). Removing the current controller stuff from the RPGDemo and moving the position updates into the Third Person Player Blueprint itself. Also taking the NPC’s and changing them to do exact position updates instead of there moveto / jump to location style updates they do now.

Would you guys be interested in a starter project like this? (11.1 only spatialos support)


#3

I think it would be wanted by a lot of people. I am still in Unity myself just because I am in no hurry to recompile 100 gigs of source code just to test Unreal. (Wish it was just a simple Plug-In). But at some point I will have to try both and having as many examples as possible is always handy. :slight_smile:


#4

I have always been interested in 3rd person starter project and was extremely disappointed when the now discredited game jam demo proved unsuitable.

My only reservation would be the question of whether your starter project would ultimately prove compatible with the revolutionary Unreal SDK changes coming in SpatialOS 12.0.

I would, however, welcome your effort and actually have been wanting something to tinker with. If it doesn’t prove to be too much work, whip it together. :slight_smile:


#5

Currently slumping alone doing the same thing for 11.1 based on the RpgDemo. It would be nice to atleast have something else to reference. I was able to get something working back in version 4.15.1 (may be SoS 10 cant remember) but it was really sloppy lol.


#7

Managed to sneak in the time to get this up and running.

Basic features include (Third person camera with zoom, forward/backwards and side to side movement, real-time position updating, rough jumping support, character rotation support)

Right now position and rotation updates happen every 0.2 seconds. This can easily be adjusted via increasing the time on the slowertick event within the Player blueprint. I have used this as a way to dynamically update the tick rate of position & rotation updates in other projects. There is no check atm for when someone is standing still but that is super easy to put in if you need it.

Also right now it is setup to teleport any player to there new location anytime the distance between there old position and new is greater then 300 units, this can easily be adjusted if you have characters that move really fast or great distances.


#8

good idea. tho it hangs at 100% after click play for some reasons. other projects works tho also spatial not logging any error


#9

Might need to do a “spatial clean” then a “spatial codegen” and then a “spatial worker build --target=local” to get it to work. I’ve tested it several times and it does work. I Walldiv also had some issues at first but he got it sorted out by doing a build on it.


#10

alright. still no luck with launching it. is it possible to launch in the cloud at all?


#11

I did end up finding a error in the NPCController Blueprint. Working on fixing it now. I imagine this is the errors you are getting when you try to package and deploy. Should have it fixed shorting.


#12

Changelog:

  • Removed the old NpcController that was causing the template to package.
  • Adjustments to the RayCast to grab the EntityID of the Actor it hits (on the server side). (Only works with when it hits a player atm)

It should now be packaging correctly / fully. I’ve tested both local deployments and cloud deployment and both work on my end now. (Not sure how I ended up missing that but its fixed now)


#13

100% same behavior. launcher hangs at unzipping at like a half of client.
another template project works tho

Also seems like launcher cache does not work. It doelwnloads entire client every launch for all projects


#14

Yeah the launcher cache I haven’t seen work yet for Unreal Projects. I just figured it was a work in progress or something.

As far as it not launching, I am not sure what is going on there. Make sure you do a clean and build for both the worker and client for cloud deployment.

I have double checked it and it should be working. I have a copy of it up and running right now.
https://goo.gl/TDee5p


#15

Hey @Tom316 / @swdan90 sorry to hear of your issues with Launcher. Caching with Unreal is certainly something we had working previously, can I confirm that caching works for you with Unity projects?

If you could send me some of your most recent Launcher logs that would help us investigate.
Thanks a lot! :slight_smile:


#16

thats new one

previous one just stopped logging at
“message”:"‘unzipping client from C:\Users\Nightingale\AppData\Local\SpatialOS\Launch\client.zip’",“time”:“Mon, 02 Oct 2017 15:57:32 GMT”,“level”:“INFO”,“name”:“launcher”}


#17

Thank you for the logs @swdan90 We’re looking into this :slight_smile:


#18

{“message”:"‘Error retrieving artifact details from assembly content service’ { status: 5,\n statusMessage: 'Artifact(UnityClient@Windows.zip) of Assembly(RpgProject) of Project(beta_eleven_skylark_257) doesn\‘t exist.’,\n headers: \n BrowserHeaders {\n keyValueMap: \n { ‘access-control-expose-headers’: [Object],\n ‘content-type’: [Object],\n ‘grpc-message’: [Object],\n ‘grpc-status’: [Object],\n vary: [Object],\n date: [Object],\n connection: [Object],\n ‘transfer-encoding’: [Object] } },\n message: null,\n trailers: \n BrowserHeaders {\n keyValueMap: \n { ‘access-control-expose-headers’: [Object],\n ‘content-type’: [Object],\n ‘grpc-message’: [Object],\n ‘grpc-status’: [Object],\n vary: [Object],\n date: [Object],\n connection: [Object],\n ‘transfer-encoding’: [Object] } } }",“time”:“Wed, 04 Oct 2017 21:05:54 GMT”,“level”:“ERROR”,“name”:“assemblyContent”}

in my other build

gotcha. now need to figure out how do i fix that.
p.s. sorry for messing a thread

UPD: solved in 12.0.4