Improbable Icon

Unreal Build Issues w/ VS 15.3.1


#1

Visual Studio 2017 15.3.1 seems to break the build process for Unreal 4.15.1 FYI

Curious if others are seeing the same.


#3

Hello @jro,

Could you maybe provide some more information on the way in which the build process appears to be broken?

Any error output and other such information would be very useful. Both for us to see whether we might have an idea of what is going on and for other developers to check whether they experience the exact same behaviour or something different if and when their build breaks too.

Best regards,
Duco


#4

@jro, @dvanamst,

With Visual Studio 2017 15.3.1 update it indeed does brick compiling the source.

They already have a fix on github: https://github.com/EpicGames/UnrealEngine/commit/6cee781ddf47558c9a59908428e7372a33774341

Basically just add "struct IUnknown; before #include <windows.h> inside Engine/Source/Programs/Windows/BootstrapPackagedGame/Private/BootstrapPackagedGame.h

Best wishes :slight_smile:
-Diz


#5

Something else must be going on for me then since that did not fix my issue.

I’m getting a bunch of MSB3075 errors:

7>ERROR : UBT error : Failed to produce item: C:\UnrealEngine\Engine\Intermediate\Build\Win64\ShaderCompileWorker\Development\ShaderCompileWorker-Core.lib
7>Total build time: 43.59 seconds (Local executor: 0.00 seconds)
7>E:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.MakeFile.Targets(44,5): error MSB3075: The command “…\Build\BatchFiles\Build.bat ShaderCompileWorker Win64 Development -waitmutex” exited with code 5. Please verify that you have sufficient rights to run this command.
7>Done building project “ShaderCompileWorker.vcxproj” – FAILED.

Worked up until VS went to 15.3, have tried just about everything I could find on the googles


#6

@jro,

There was also another mention about updating to some insider Windows SDK 10.0.0 version… use at your own risk. Keep in mind this post is focused on 4.17 but it might be due to visual studio includes (SDK)

https://answers.unrealengine.com/questions/688112/ue417-will-not-compile-with-new-153-update.html


#7

Tried building with the latest insider win10sdk (and updating the use sdk10 to true) as well as re-targeting the project to it but same result.

I did the same procedure on another machine I have that had 1.5.0 on it and it built fine. After upgrading VS to 1.5.3 building failed with the same issues. Those declspec errors are from something they added in 1.5.3, wondering if related:

New warning on declspec attributes

In Visual Studio 2017 version 15.3, the compiler no longer ignores attributes if __declspec(…) is applied before extern “C” linkage specification. Previously, the compiler would ignore the attritbute, which could have runtime implications. When the /Wall /WX option is set, the following code produces “warning C4768: __declspec attributes before linkage specification are ignored”:

https://docs.microsoft.com/en-us/cpp/cpp-conformance-improvements-2017