Improbable Icon

SpatialOS Discourse Forums

Worker SDK Upgrade

Hello SpatialOS devs,

We’ve made a few tweaks to SpatialOS and wanted to let you know how they’ll affect you and your game.

Due to recent protocol upgrades, you may need to update your SpatialOS GDK or SDK by 1st August.

We’ve updated the protocols relating to our earlier Worker SDKs. We’re removing support for the old ones to ensure the platform’s security. You’ll need to upgrade to the most recent Worker SDK or GDK for Unreal or Unity by 1st August 2020.

If you are already using the following, then you don’t need to do anything.

  • GDK for Unreal 0.8.1 or later
  • GDK for Unity 0.3.4 or later
  • Worker SDK 14.5.0 or later

If you’re using an earlier integration then you’ll need to upgrade.

Here’s how to find out which version you’re using:

GDK For Unreal users:
Navigate to either:

  • Engine
    /[UE4 Root]/Engine/Plugins/UnrealGDK/

  • Project
    /[Project Root]/Plugins/UnrealGDK/

Check the CHANGELOG.md in one of the above paths. The top version is the version you’re currently using.

GDK for Unity users:
Navigate to \workers\unity\Packages within your project and see what version of the io.improbable.packages you are using, this is your GDK version.

Worker SDK users:
Simply check the top few lines of the worker log files. You’ll find the relevant documentation here.

If you have any issues during this process please don’t hesitate to get in touch,

The Improbable Team